Issue
When attempting to join a Zoom meeting, users may receive an error message indicating This meeting ID is not valid. Please check and try again.
Cause
Host has 'Ended' the Meeting
You may be presented with the invalid meeting ID error if the host (for example, your instructor) has ended or cancelled the meeting.
Meeting ID is Not Accurate
You may be using an incorrect meeting ID number when attempting to join the meeting.
Workaround
Option 1
If the meeting is still in progress, verify the meeting ID number provided to you by the host (for example, your instructor) and input the ID number in the Join a Meeting dialog box.
Option 2
If the meeting is still in progress, ask the host (for example, your instructor) to send a new invite to you.
Need Technical Assistance?
Submit a ticket to Zoom.