Skip to Knowledge Base content

Supported Browsers and Technology for D2L

Supported Browsers

To ensure that your D2L experience is as seamless as possible, we recommend that you review the technical requirements at the link below and keep your workstation up to date with a supported browser version. By using non-supported technology, you may experience technical difficulties that cannot be corrected.

Brightspace by D2L Platform Requirements

For the best performance, only use devices and browsers with a status of Supported, and verify that your browser has JavaScript and Cookies enabled. Additionally, ensure that you have Adobe Flash Player installed if you would like to use the Record Audio and Record Video features. The section below will explain where you can find software and plug-ins if you do not have them.

Software and Plug-Ins

The following plugins and software are required to use D2L, and will be needed if you choose to view and use interactive and/or downloadable content. Each program is freely available on the internet. Click on each of the links below to download and install each plug-in and program that may be used in the LMS.

Plug-Ins

  • Adobe Flash is needed to view certain types of embedded interactive content, such as YouTube videos.
  • Oracle Java is needed for enhanced features in D2L, such as the Equation Editor when creating an HTML page.

Software

  • MS Word Viewer is useful if you do not have MS Office, but need to view a Word document.
  • MS PowerPoint Viewer is useful if you do not have MS Office, but need to view a PowerPoint presentation.
  • MS Excel Viewer is useful if you do not have MS Office, but need to view an Excel spreadsheet.
  • Adobe Reader is useful if you do not have Adobe Acrobat, but need to view a .PDF document.

Note: Specific courses or programs may require additional software and hardware. Be sure to check the individual course requirements.

Was this helpful?
0 reviews

Details

Article ID: 11845
Created
Wed 3/23/16 8:11 AM
Modified
Thu 6/22/17 9:46 AM